HELP - Jasman Halo 3 Plasma Rifle Laser Tag Wiring Repair

SaltyDalty

New Member
So I recently was able to get my hands on one of my most sought after items for my Halo collection; the Halo 3 Jasman plasma rifle laser tag gun. Got it for a pretty good deal on Ebay. The seller said it worked before he shipped it. Once it arrived I put in a fresh set of batteries andddd nothing. No power. Disassembled it and found a black wire on the back of the ON-OFF-DEMO switch had been broken off the solder. I tried Googling and found one article on here about a different wiring issue but he had pictures of the back of the switch posted but they were old and blurry so I couldn't pinpoint where the black wire goes. I have soldering skills so no worry there. There is also zero corrosion on this plasma rifle so that's not it either. Does anyone have one they could partially disassemble (only 3 Phillips head screws need removed) and post a picture of the wiring on the back of the power switch? My last picture is the 3 screws that need removed in red. I would greatly appreciate it! Thanks in advance! I attached some pics of mine so you can see what I'm talking about.
 

Attachments

  • IMG_1483.jpeg
    IMG_1483.jpeg
    3.7 MB · Views: 38
  • IMG_1482.jpeg
    IMG_1482.jpeg
    108.8 KB · Views: 34
  • IMG_1481.jpeg
    IMG_1481.jpeg
    130.2 KB · Views: 34
  • IMG_1484.jpeg
    IMG_1484.jpeg
    541.7 KB · Views: 38
Does anyone have one they could partially disassemble (only 3 Phillips head screws need removed) and post a picture of the wiring on the back of the power switch?
Attached are (5) images of my plasma rifle, now this one I bought in rough shape purely for the fins. Which I must thank you! I had no idea the bottom fin plate is only 3 bolts! That helps me a ton! I never did dive in to the disassembly stage but still, thanks for little push I suppose.

Anyway.. I can check my first laser tag plasma rifle that I know functions to check on the black wire.
 

Attachments

  • IMG_7041.jpg
    IMG_7041.jpg
    519.5 KB · Views: 27
  • IMG_7040.jpg
    IMG_7040.jpg
    517.5 KB · Views: 27
  • IMG_7039.jpg
    IMG_7039.jpg
    660.3 KB · Views: 24
  • IMG_7038.jpg
    IMG_7038.jpg
    648.3 KB · Views: 26
  • IMG_7043.jpg
    IMG_7043.jpg
    510.5 KB · Views: 26
Alrighty, looks like we have a winner here! Attached are (6) more images of my first Jasman plasma rifle. This one works but all of the fins were damaged/not present which led me to get a second to cast the fins. (Still have not done that bit). This rifle does work, fires, sounds, vibrations. The only exception is my top fins do not come out when "overheating".

Hope this helps!
 

Attachments

  • IMG_7049.jpg
    IMG_7049.jpg
    479.9 KB · Views: 26
  • IMG_7048.jpg
    IMG_7048.jpg
    432.6 KB · Views: 29
  • IMG_7047.jpg
    IMG_7047.jpg
    491.8 KB · Views: 22
  • IMG_7046.jpg
    IMG_7046.jpg
    462.1 KB · Views: 26
  • IMG_7045.jpg
    IMG_7045.jpg
    516.1 KB · Views: 26
  • IMG_7044.jpg
    IMG_7044.jpg
    596 KB · Views: 29
Alrighty, looks like we have a winner here! Attached are (6) more images of my first Jasman plasma rifle. This one works but all of the fins were damaged/not present which led me to get a second to cast the fins. (Still have not done that bit). This rifle does work, fires, sounds, vibrations. The only exception is my top fins do not come out when "overheating".

Hope this helps!
You are AWESOME. Thank you so much! I will work on repairing mine tomorrow and see if that fixes my issues. Again thank you so much!!
 
You are AWESOME. Thank you so much! I will work on repairing mine tomorrow and see if that fixes my issues. Again thank you so much!!
You got it! Good luck and be sure to post your results, whether it fails or succeeds! I'm curious to know how it goes.
 
Alrighty, looks like we have a winner here! Attached are (6) more images of my first Jasman plasma rifle. This one works but all of the fins were damaged/not present which led me to get a second to cast the fins. (Still have not done that bit). This rifle does work, fires, sounds, vibrations. The only exception is my top fins do not come out when "overheating".

Hope this helps!
Man, I just want to say thank you so much again! I finally had some free time and was able to get back to repairing it and it worked! Resoldered the wire exactly as yours are and it fixed it! All lights and sounds work now. Even tested it on the target that my plasma pistol came with and it works on there too. Now to try and find out why the fins don't pop out on their own and the reload button sticks a slight bit occasionally. But anyways thank you so much again! Hope you have a great weekend!!!
 

Attachments

  • IMG_1590.jpeg
    IMG_1590.jpeg
    2.6 MB · Views: 13
Heck yeah, my weekend was good and I'm glad things worked out for ya! If you continue to disassemble more or make adjustments I'd be keen to see more. Well done!
 
Heck yeah, my weekend was good and I'm glad things worked out for ya! If you continue to disassemble more or make adjustments I'd be keen to see more. Well done!
For sure, will do! I plan on taking the top portion apart at some point and seeing if I can fix the fins not automatically coming out and the reload button sticking. When I do I'll take plenty of pictures and upload them here.
 

Your message may be considered spam for the following reasons:

If you wish to reply despite these issues, check the box below before replying.
Be aware that malicious compliance may result in more severe penalties.
Back
Top