3D printer HELP thread

BuckDenali

New Member
You would want to reduce as much time printing the supports as possible. In my personal opinion, I always print the smoothest part facing down so the supports can stabilize it as the printer builds it.
Should I slice the helmet in half from top to bottom or back and front?
 
It is the ODST helmet from Halo 3.
After taking a look at the helmet, I think it would be better to, in my opinion, go half from top to bottom. But you might want to print the top half upside down. Here's what I would do. If you can find other videos printing this exact helmet, follow their example.
 

BuckDenali

New Member
After taking a look at the helmet, I think it would be better to, in my opinion, go half from top to bottom. But you might want to print the top half upside down. Here's what I would do. If you can find other videos printing this exact helmet, follow their example.
I did find one video. It appears the person prints it out in multiple pieces. It looks like this particular person sliced it back and front. I will attempt to print it top and bottom and see the results... Lol wish me luck.
 
Cool. Just as a reminder, you can also check out how things will print in the slicer program to get a better idea how things could turn out.
 

Coreforge

Member
I've recently upgraded my printer to TMC2209 drivers, but with these drivers my motors have been skipping steps which resultet in layer shifts. I tried upping the motor current and lowering acceleration which helped, but I still got skipped steps. The print time also about doubled. The issue persists in both stealthchop and spreadcycle mode. I'm running the drivers in 1/16th microstep mode, if it has anything to do with interpolation. It worked fine eith A4988 drivers, but those were too loud. I'd appreciate it if anyone could help me with this problem.
 

TurboCharizard

Division PR, RMO and BCO
Division Staff
405th Regiment Officer
Community Staff
I've recently upgraded my printer to TMC2209 drivers, but with these drivers my motors have been skipping steps which resultet in layer shifts. I tried upping the motor current and lowering acceleration which helped, but I still got skipped steps. The print time also about doubled. The issue persists in both stealthchop and spreadcycle mode. I'm running the drivers in 1/16th microstep mode, if it has anything to do with interpolation. It worked fine eith A4988 drivers, but those were too loud. I'd appreciate it if anyone could help me with this problem.
What's the board you're using with those stepper drivers? Do you have any smoothing diodes or anything downstream from the drivers to the motors?

Turning acceleration down makes sense that you're seeing longer print times, I can see that you're aiming for a smoother print overall, what's your travel and print speeds like?

Have you tried tuning your Vref for the axis that is layer shifting?
 

Coreforge

Member
I'm using the drivers on a RAMPS 1.4 clone with repetier firmware. I haven't added anything downstream from the drivers to the motors and I don't think the board has anything either. I'm printing at 60mm/s with 35mm/s for first layer and walls and 150mm/s travel. I turned the current up to 1.2A (the motors are only rated for 1.4A) which helped, but I still got some shifting. The motors take some force to stop them, so I wouln't think that that's the problem. The travel acceleration is at 300mm/s^2 and manual travel speed is at 200mm/s which works fine. The shifting also didn't occur always on the same layer, but always within the first few mm.
 

Coreforge

Member
I solved this issue now by homing X and Y after every Layer, which reduces the amount of issues lost steps cause. I'm doing this with the "Insert after layer change" script in cura, though this adds the homing command in the wrong place, so I have to manually copy it to the right line. I'll try to automate this in the future, but for now this has to work. I was also able to turn the acceleration up to 1200mm/s^2 without losing steps at 15000mm/min.
 

MoeSizzlac

Active Member
I solved this issue now by homing X and Y after every Layer, which reduces the amount of issues lost steps cause. I'm doing this with the "Insert after layer change" script in cura, though this adds the homing command in the wrong place, so I have to manually copy it to the right line. I'll try to automate this in the future, but for now this has to work. I was also able to turn the acceleration up to 1200mm/s^2 without losing steps at 15000mm/min.
Dear Lord that seems tedious.
 

Coreforge

Member
I kinda solved it now by adding a second fan that blows air onto the stepper drivers from the top instead of from the sides. I still got some small layer shifts, but they occures a few hours later than before, and since I'm homing after each layer, their impact isn't as big. I'll try to lower the current on the X motors again to 800mA, as that current had enough torque and might help with the remaining heat problem.
 

LoneBlackfang

New Member
As for armor I am currently working on converting the files here in to printable files. If you need any of the armor files converted let me know
 

NotTheArbiter

New Member
I kinda solved it now by adding a second fan that blows air onto the stepper drivers from the top instead of from the sides. I still got some small layer shifts, but they occures a few hours later than before, and since I'm homing after each layer, their impact isn't as big. I'll try to lower the current on the X motors again to 800mA, as that current had enough torque and might help with the remaining heat problem.
I am not sure if that helps you now after that time, but it's a bit odd that the steppers get that hot. I had mine on a Ramps 1.4 board tuned to around 0.5 or 0.8V (cannot say by heart) and they run now very cool and quiet, as before they got kinda warm after 4 hours. Now they are cool, even after a 10 hour print.
Layer shifting can be caused due to too high tool head movement speeds, but you said you already tackled it and it works usually fine, but for the first mm. I'd try to go with the stepper voltage a bit lower to tackle heat, while still remaining enough torque. Back then, when I had my printer new with the stock settings, I had to put an aluminium block on the y-axis motor to help with cooling. Very annoying times.
 

Coreforge

Member
I solved it a while ago by switching to Marlin, which supports these drivers in UART mode, so they can get switched between Stealthchop and Spreadcycle depending on speed. I also tightned up the belts, as that was also causing some issues.
 
Top